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2 Week-15 (Java GUI Programming)

2.0.0.1 Fall Semester, 2021-2022 Download DOC!, SLIDE?, PPTX?

2.1 Java GUI Programming

2.2 JavaFX GUI Programming

2.2.1 1-Install Gluon Scene Builder

Download and Install Gluon Scene Builder from URL
Scene Builder - Gluon*

We will use gluon scene builder as an external designer for NetBeans, Eclipse, and IntelliJ idea tools.

Lcel03-week-15-java-gui.en.md_ doc.pdf
2ce103-week-15-java-gui.en.md_ slide.pdf
3cel03-week-15-java-gui.en.md_ slide.pptx
4https://gluonhq.com/products/scene-builder/
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you can save this design as an FXML file from File->Save As

2.2.2 2-Install Apache Netbeans
Download and install apache Netbeans

https://netbeans.apache.org/
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Apache MNetBeans IDE 12.6

Reading module starage...
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IJ Apache NetBeans IDE Installer — O bt

Welcome to the Apache NetBeans IDE 12.6 Installer

The installer will install the MetBeans IDE with the following packs and runtimes.
Click Customize to select the packs and runtimes to install,

Base IDE

Java SE

Java EE
HTMLS/JavaScript
PHP

W Anache Customize. .. Installation Size: 761,59 MB
MetBeans IDE




l:,l Apache MetBeans IDE Installer

— O o
Apache NetBeans IDE 12.6 Installation % Apache
) ] NetBeansIDE
Chonse the installation folder and JDK™,
Install the Apache MetBeans IDE to:
|C:‘|,Prngram Files\MetBeans-12.6 | | Browse. .. |

DK™ for the Apache MetBeans IDE:

|C:‘|Program Files\lavatjdk-16.0.1

v|| Browse... |

< Back || Next > | | Cancel




LJ Apache MetBeans IDE Installer

Summary

Click Install to start the installation.

Base IDE Installation Folder:
C:'Program Files\MetBeans-12.6

Check for Updates

The MetBeans installer can automatically check for updates of installed plugins

using your Internet connection,

Total Installation Size:
761,59 MB

< Back

Cancel



U

Setup Complete Apache
U NetBeansIDE
Click Finish to complete the Apache NetBeans IDE setup.

Installation completed successfully.
All plugins are up to date,
To launch the IDE, use either the Start menu or the Apache NetBeans desktop icon,

To change installed components and add MetBeans plugins, use Plugin Manager that is an integral part of Apache
MetBeans IDE.

2.2.3 3- Configure JavaFX Scene Builder for Apache Netbeans
Open Tools->Options->Java->JavaFX
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Scene Builder Home: Please, select a valid Scene Builder home... ~

[] Save All Modified Files Before Running Scene Builder

Export... Import... Apply Cancel Help

Select builder home
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L) Options x

% E \ié& & E @ G III[‘.]E:I d% &, |Filter (Ctrl+F)

General Editor Fonts & Colors Keymap | Java | HTML/JS PHP C/C++ Team Appearance Miscellaneous

Ant GUIBuilder Gradle JavaShell Maven JavaFX Java Debugger JSon WM Profiler

JavaFX Scene Builder Integration
Scene Builder Home: | £i\SceneBuilderGluon

Save All Modified Files Before Running Scene Builder

Export... Impaort... Apply Cancel Help

you can find old integration documentation here

Using JavaFX Scene Builder with Java IDEs: Using Scene Builder with NetBeans IDE | JavaFX 2 Tutorials
and Documentation®

2.2.4 4-Create First Application
Select File->New Project

Shttps://docs.oracle.com /javafx/scenebuilder/1/use_java_ides/sb-with-nb.htm
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L) Apache NetBeans IDE 12.6
File Edit View Mavigate Source Refactor Run Deb

T New Project... Ctrl+Shift+N
T Mew File... Ctrl+N
Open Project... Ctrl+Shift+0

Open Recent Project
Close Project

Close Other Projects

Select Java With Maven Types
FXML JavaFX Maven Archetype (Gluon)

LJ Mew Project
Steps Choose Project
1. Choose Project L Filter:
2.
Categories: Projects:
-1 Java with Maven % Enterprise Application
-7 Java with Gradle % Ente.rpriseﬁ.pplication Client
[ Java with Ant 1 ﬁfﬁ' B“”f': o
[ HTMLS/JavaScript eranatr. } raje
B % MetBeans Maodule
C/Ce+ E}J MNetBeans Application
- PHP 5 Payara Micro Application
@[ Samples = WFXML JavaFX Maven Archetype (Gluon)
@ Simple JavaFX Maven Archetype (Gluon)
lile POM Project
lile Project from Archetype
{2 Project with Existing POM
Description:

A simple JavaFX application using Maven. For details, see https://openjfx.io/openfx-docs.

< Back Finish Cancel Help

Set project properties

12



L1 MNew FXML JavaFX Maven Archetype (Gluen)

Steps Name and Location

1. Choose Project

Project Marme: [ first-javafx-app
2. MName and Location

Project Location: | C\Users\ugur.coruh\Desktopnetbeans Browse...

Project Folder: | C\Users\ugur.coruh\Desktop'\netbeans\first-javafx-app

Artifact |d: first-javafx-app
Group Id: com.ucoruh
Version: 1.0-5MAPSHOT
Package: com.ucoruh.first.javafx.app {Optional)
Additional Creation Properties:
Key Yalue
javafx-version 13
javafx-maven-plugin-version 0.0.4
add-debug-cenfiguration Al

< Back Mext = Cancel Help

Open Project Resources and Click FXML files to run Scene Builder

13



L) first-javafx-app - Apache NetBeans IDE 12.6
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Then you can run applications from Netbeans.
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L) first-javafx-app - Apache NetBeans IDE 12.6
File Edit View Mavigate Socurce Refactor Run Debug Profile Team Tools Window Help

'1F_"] % I—' -.\-é'—'.l <default config> v u- I:E) % |> i - @ . WLE
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for introduction level information please check the following examples

JavaFX Simple Calculator - Design and Code - YouTube®

JavaFX Library Management System Development #0: Introduction - YouTube”
for more information about JavaFX please check the following

JavaFX Tutorial - javatpoint®

2.3 Java Swing GUI Programming

Select File->New Project -> Java with Maven -> Java Application

Shttps://www.youtube.com/watch?v=o0Wk9fwRgV__k&ab_ channel=qBit
Thttps://www.youtube.com/watch?v=9d3X8eBovlM&ab_ channel=GenuineCoder
8https://www.javatpoint.com /javafx-tutorial
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L) Mew Project

>
Steps Choose Project
1. Choose Project L Filter:
2
Categories: Projects:

=[] Java with Maven
=[] Java with Gradle
-7 Java with Ant

- [ HTML5/JavaScript
-0 CfCr+

= 3 Java Application
M Java Frontend Application
Web Application

EIB Module

Enterprise Application
Enterprise Application Client

@
@
=,
<[ pHe % 05Gi Bundle
-1 Samples M Micronaut Project
% MNetBeans Module
i MetBeans Application
5 Payara Micro Application
@ FXML JavaFX Maven Archetype (Gluon) h
Description:

new to Javal

A simple Java SE application using Maven. You are recommended to begin here, if you are

Configure Project

< Back Finish Cancel Help

17



LJ Mew Java Application

Steps

Mame and Location

1. Choose Project
2. MName and Location

Project Name:

first-javaswing-ap pl

Project Location: | C:\Users\ugur.coruh\Desktopinetbeans Browse...

Project Folder:  |T:\Users\ugur.coruh\Desktophnetbeans\first-javaswing-app

Artifact Id: first-javaswing-app

Group Id: com.uceruh

Version: 1.0-5MAPSHOT

Package: com.uceruh.firstjavaswing.app (Optional)
< Back Mext = Cancel Help

Open project and select package then select right-click -> New -> JFrame Form

18



L) first-javaswing-app - Apache MetBeans IDE 12.6

File Edit View Mavigate Source

Refactor Run Debug Profile Team Tools Window Help

ﬁ % I—‘Eflj @ |<default config>
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1O T% b5 G- sl

- b first-javafx-app
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EEL Project Files

Give a name to your frame

19

—  Start Page
Source | |
: 1 H
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P EEQ com.ucoruh first. javaswp 3 .
: ir
- g Dependencies 5T (3 Folder.. 2 % ;
- g Java Dependencies Find... Ctrl+F =] JFrame Form.. H
: 5
@ Java Class...
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[ Java Package... 7
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L) Mew JFrame Form X

Steps Mame and Location

1. Choose File Type
2. MName and Location

Class Name: |[YEUISELY

Project: first-javaswing-app

Location: Source Packages w

Package: corm.uceruh.first javaswing.app w

Created File: Ch\Users\ugur.coruh\Desktop'netbeans\first-javaswing-apphsrcimainljavatcom

Superclass: Browse...

Interfaces: Browse...

< Back Mext » Cancel Help

Swing GUI Builder is integrated with Netbeans

Q) first-javaswing-app - Apache NetBeans IDE 12.6 -
File Edit View Navigste Source Refactor Run Debug Profile Tesm Tools Window Help Q- Serch (Crl+)

L) & D @ [ V| QT B DB @ - psesenrsy (s Cb

Files  Services —  StartPage x | [§] PrimaryControllerjava x | [8 Appjava x | [ NewlFramejava x v O Palette [ [Frame] -Properties x
B first-javafi-app Source | Design | History | Y [ | BT Iafe | & ¢ || Properties  Events  Code
=@ first-javaswing-app = Properties.
I8 Source Packages @ To change of a container use Set L its context defaultCloseOperation EXITON_CLOSE o
& comucoruhfirstjavaswing.app e
B NewFramejova |=/0ther Properties.
?Epﬁsdﬁ"ﬂ:i alwaysOnTop ]
ava Dependencies alwaysOnTopSupported
5 pejefio e
backgrouna O re02¢0.2¢01
bouncs <Not set>
cursor Default Cursor v
enabled
extendeastate o
focusCycleRoot
focusTraversaPolicy <defauit> <
focusTraversaPolicyProvider
focusable
focusableWindowState
font ot
foreground ot
oraphics <none>
iconimage <none> ~
iconimages Sdefaut> v
insets 10.0,0,0
location <Not set>
UFrame] - Navigator x - locationsyPltiorm ]
B Form NewFrame maximizedBounds null
3 Other Components maximumsize (2147483647, 2147483647)
[F] UFrame] minimumSize 10,01
WFrame]

Notifications | Output - Run (frst-javaf-app) X

er-plugin:a.8.0 le (s
Changes detected - recompiling the module!
Compiling 4 souree files to

<<< Javafu-maven-plugin:0.0.4:run (default-sli) < process-classes @ first-Javafu-app <<<

XORISS

BUILD Succass

Toval wime: 15.142
Finished st: 2022-01-11T01:4€:08403:00

Drag-and-drop controls to panel from the palette

20




| =]

Palette = | [JFrame] - Properties

= Swing Containers

|:| Panel ﬁ Tabbed Pane il Split Pane

Q Scroll Pane LD Tool Bar .=.% Desktop Pane
ﬁ Internal Frame E| Layered Pane

= Swing Controls

el [abel Button Toggle Button
= Check Box ®— Radio Button %Z Button Group
[I=] Combo Box =] List [ Text Field
Text Area BEL Scroll Bar db Slider

1 Progress Bar
=] Spinner

Editor Pane
= Swing Menus
[Fil: Menu Bar
|:| Menu ltem

|25 Menu Item / RadioButton

H Separator

= Swing Windows
Dialog

=| Swing Fillers
@ Glue

il Rigid Area

I+ AWT
[+ Beans

Formatted Field

H Separator
Tree

Menu

[-=] Password Field
Text Pane
=] Table

55 Menu Item / CheckBox

Frame
Option Pane

<~ Horizontal Glue
@ Vertical Glue

Popup Menu

Color Chooser

F Herizontal Strut
]I Vertical Strut
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And from the events tab, add custom actions.

Properties  Events Code
[=|Events P
actionPerformed “nonex ot |:|
ancestorfdded “nonex ot |:|
ancestorMoved “nonex ot |:|
ancestorMoved “nonex ot |:|
ancestorRemoved “nonex ot |:|
ancestorResized “nonex ot |:|
caretPositionChanged “<nonex et |:|
componentadded “<nonex et |:|
componentHidden “<nonex et |:|
componentMoved “<nonex et |:|
componentRemoved “<nonex et |:|
componentResized “<nonex et |:|
componentShown “<nonex et |:|
focusGained “nonex ot |:|
focuslLost “nonex ot |:|
higrarchyChanged “<nonex et |:|
inputMethodTextChanged <none> vl
tem=tateChanged “<nonex et |:|
kevPressed “<nonex et |:|
kevHeleazed “<nonex et |:|
keyTyped “<nonex st |:|
mougeClicked |Butten1MouseClicked e |:|
mouselragged “<nonex et |:|
mouzeEntered “nonex ot |:|
mouseExited “nonex ot |:|
mouseioved “nonex ot |:|
mousePressed “nonex ot |:| v
- /1
jButton1 [JButton] (7]

you can configure control properties from the properties screen

22




Palette | |Buttonl [JButton] - Properties = —_

Properties Events Code
[=I Properties ﬁ
action “nonex> w .
background (] [240,240,240]
font Segoe Ul 12 Plain
foreground W (0,00
icon “nonex> w .
mnemonic
text JButton
tooMipText
(=l Other Properties
UIClas=ID ButtonUl
actionCommand JButton
alignmentX 0.0
alignmenty’ 0.5
autoscrolls |:|
baselineResizeBehavior CEMTER_OFFSET
border [XPEmptyBorder]
borderPainted
buttonGroup < none> L
componentPopupMenu < none> L
content&reaFilled
CUrsor Default Cursor ...
debugGraphicsOptions MO _CHAMGES w ...
defauttCapable
dizabledicon “nonex> w .
dizabledZelectedicon “nonex> w .
displayedMnemonicindex -1
doubleBuffered [] 9
jButton1 [JButton] (7]

We can add simple events such as when the moclickscked to button write text on the text field

23



“Hello World”

@SuppressWarnings ("uncheckesd™)
Generated Code

jImFiﬂdl .getText ("Hello World™):;

// TODD add your handling code here:

YAL:

? * @param args the command line arguments

When you run application, you will see the following screen

B — O ¥

2.3.1 References
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